SO I’ve been trying to create a bootable live USB of some linux distro on the Mac and failed consistently. That is – until I found a magical solution!
I tried
dd
-ing the .iso file onto the USB stick after unmounting, (and optionally partitioning to “Free Space” with Disk Utility)- Formatting to FAT32, then copying from .iso
- Using UNetBootin for Mac OS X, that basically copies stuff and then adds its own bootloader “GUI”
Nothing worked. I kept getting “Missing Operating System” or just failures on boot…
Until I found a post by this guy Christofer, who published a very important piece of information that got me through the problem:
I needed to write the MBR to the USB after formatting to FAT32 because UNetBootin (or anything else) did not do that…
http://perpetual-notion.blogspot.com/2011/08/unetbootin-on-mac-os-x.html
Basically the procedure is simple:
1. Format to FAT32 with Disk Utility
Make sure you select the Master Boot Record
2. Use fdisk to write the MBR to partition #1
Make sure you first unmount the partition using DiskUtil (or command line: diskutil umount /dev/disk1s1
)
fdisk -e /dev/rdisk1 f 1 write exit
(it may complain a bit, but should work, just keep going)
3. get syslinux and upload the MBR binary
I had to use “/dev/disk1” instead of “/dev/rdisk1” to make it work.
dd conv=notrunc bs=440 count=1 if=mbr.bin of=/dev/disk1
You should see
1+0 records in 1+0 records out 440 bytes transferred in 0.000622 secs (707628 bytes/sec)
I’ve found the mbr.bin in the latest syslinux download under
syslinux-6.02/bios/mbr/mbr.bin
.
4. Use UNetBootin as usual
That worked for me…